summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-12-25 19:24:14 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-12-26 02:04:48 +0000
commitda0bf376937f65083bf81f3ad8f1f01bde29ac04 (patch)
treeb9d35d567cf9513bd5300273ac658242d70292fa /dev-python/boto3/boto3-1.5.6.ebuild
parentdev-python/botocore: simplify *DEPEND declaration (diff)
downloadgentoo-da0bf376937f65083bf81f3ad8f1f01bde29ac04.tar.gz
gentoo-da0bf376937f65083bf81f3ad8f1f01bde29ac04.tar.bz2
gentoo-da0bf376937f65083bf81f3ad8f1f01bde29ac04.zip
dev-python/boto3: add new 1.5.6 version
botocore version requirement updated per upstream info. Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-python/boto3/boto3-1.5.6.ebuild')
-rw-r--r--dev-python/boto3/boto3-1.5.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/boto3/boto3-1.5.6.ebuild b/dev-python/boto3/boto3-1.5.6.ebuild
new file mode 100644
index 000000000000..e5e0c5c1a656
--- /dev/null
+++ b/dev-python/boto3/boto3-1.5.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/botocore-1.8.20[${PYTHON_USEDEP}]
+ <dev-python/botocore-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.1.10[${PYTHON_USEDEP}]
+ <dev-python/s3transfer-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ ~dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}