summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 22:44:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:21 +0100
commitdcc1abb5c0f274dd860d2913160962b1d069321f (patch)
treedd4572bfec37fd44ed69dcb0a1c166d7a3047d9b /dev-python/botocore/botocore-9999.ebuild
parentnet-misc/owncloud-client: 2.10.0.6519 bump (diff)
downloadgentoo-dcc1abb5c0f274dd860d2913160962b1d069321f.tar.gz
gentoo-dcc1abb5c0f274dd860d2913160962b1d069321f.tar.bz2
gentoo-dcc1abb5c0f274dd860d2913160962b1d069321f.zip
dev-python/botocore: Bump to 1.23.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 80a198d56414..79a1cd5da0e2 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,7 +17,7 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
RDEPEND="
@@ -60,6 +61,5 @@ python_test() {
tests/functional/test_six_threading.py::test_six_thread_safety
)
- distutils_install_for_testing --via-venv
epytest tests/{functional,unit}
}