summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 09:22:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:48 +0100
commit25e32ee384088923b56e78198e9dd216637fae59 (patch)
treeacd60fd7d2a8b6c21d97937830f82547446fc610 /dev-python/catkin_pkg/catkin_pkg-9999.ebuild
parentdev-ros/rqt_gui: Add python 3.4/3.5 support (diff)
downloadgentoo-25e32ee384088923b56e78198e9dd216637fae59.tar.gz
gentoo-25e32ee384088923b56e78198e9dd216637fae59.tar.bz2
gentoo-25e32ee384088923b56e78198e9dd216637fae59.zip
dev-python/catkin_pkg: Allow having package.xml in ros_packages subdir without triggering duplicate.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-9999.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 57cbb8ced996..e258fe5491b9 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -35,15 +35,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" "${FILESDIR}/ros_packages.patch" )
python_test() {
nosetests -s --tests test || die
}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Avoid recursing in the whole hierarchy
- dodir /usr/
- touch "${ED}/usr/CATKIN_IGNORE"
-}