summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 20:07:11 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 20:18:24 +0200
commit6502d44346a2ed4c29c6b64c9b634e67e5025802 (patch)
treeca8ee525f4743221db4d040e10e2d9cbb6bb2f59 /dev-python/cssselect/cssselect-0.9.2.ebuild
parentdev-python/xlsxwriter: Bump (diff)
downloadgentoo-6502d44346a2ed4c29c6b64c9b634e67e5025802.tar.gz
gentoo-6502d44346a2ed4c29c6b64c9b634e67e5025802.tar.bz2
gentoo-6502d44346a2ed4c29c6b64c9b634e67e5025802.zip
dev-python/cssselect: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/cssselect/cssselect-0.9.2.ebuild')
-rw-r--r--dev-python/cssselect/cssselect-0.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/cssselect/cssselect-0.9.2.ebuild b/dev-python/cssselect/cssselect-0.9.2.ebuild
new file mode 100644
index 000000000000..ce7cfbc4f88a
--- /dev/null
+++ b/dev-python/cssselect/cssselect-0.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="parses CSS3 Selectors and translates them to XPath 1.0"
+HOMEPAGE="http://packages.python.org/cssselect/ https://pypi.python.org/pypi/cssselect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_prepare_all() {
+ # prevent non essential d'load of files in doc build
+ sed -e 's:intersphinx_:#&:' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc ; then
+ "${PYTHON}" setup.py build_sphinx || die
+ fi
+}
+
+python_test() {
+ "${PYTHON}" ${PN}/tests.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}