summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 10:11:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 10:51:38 +0100
commit02964c42a225eb98bf54ac9460d86287311a40a8 (patch)
tree5cd82db682fc0579595c91818d646908e2f0c225 /dev-python/debtcollector/debtcollector-2.4.0.ebuild
parentdev-python/pytest-asyncio: Bump to 0.17.2 (diff)
downloadgentoo-02964c42a225eb98bf54ac9460d86287311a40a8.tar.gz
gentoo-02964c42a225eb98bf54ac9460d86287311a40a8.tar.bz2
gentoo-02964c42a225eb98bf54ac9460d86287311a40a8.zip
dev-python/debtcollector: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debtcollector/debtcollector-2.4.0.ebuild')
-rw-r--r--dev-python/debtcollector/debtcollector-2.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/debtcollector/debtcollector-2.4.0.ebuild b/dev-python/debtcollector/debtcollector-2.4.0.ebuild
new file mode 100644
index 000000000000..fdd005b4f461
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-2.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest