summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-11-18 16:59:53 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-18 16:59:53 -0500
commit2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905 (patch)
tree8bd251e276b1baceb132991568feb127333f2b4f /dev-python/diskcache/diskcache-3.1.0.ebuild
parentdev-python/filelock: add missing Manifest (diff)
downloadgentoo-2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905.tar.gz
gentoo-2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905.tar.bz2
gentoo-2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905.zip
dev-python/diskcache: bump to 3.1.0
Previous version didn't support newer django. Also, add missing "sqlite" in PYTHON_REQ_USE. Closes: https://bugs.gentoo.org/636554 Closes: https://bugs.gentoo.org/636406 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/diskcache/diskcache-3.1.0.ebuild')
-rw-r--r--dev-python/diskcache/diskcache-3.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/diskcache/diskcache-3.1.0.ebuild b/dev-python/diskcache/diskcache-3.1.0.ebuild
new file mode 100644
index 000000000000..e0c59c1bf649
--- /dev/null
+++ b/dev-python/diskcache/diskcache-3.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "failed with ${PYTHON}"
+}