summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 22:03:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 22:09:36 +0100
commit4edc99a641749b271f518524da77ad5bd80e45be (patch)
tree8e8871b9ebe0e27062cbc66df5b90ad508397696 /dev-python/entrypoints/entrypoints-0.3-r1.ebuild
parentdev-python/tappy: Replace virts with cond deps (diff)
downloadgentoo-4edc99a641749b271f518524da77ad5bd80e45be.tar.gz
gentoo-4edc99a641749b271f518524da77ad5bd80e45be.tar.bz2
gentoo-4edc99a641749b271f518524da77ad5bd80e45be.zip
dev-python/entrypoints: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/entrypoints/entrypoints-0.3-r1.ebuild')
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
index 0b64e872fe36..0eb427f32fa5 100644
--- a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
+++ b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
@@ -19,13 +19,15 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' -2)
"
BDEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pathlib[${PYTHON_USEDEP}]
+ ' -2)
)
"