summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-09 11:37:27 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-09 11:49:37 +0200
commita7e6cd2c880d2e40d6fbc36018e485f0fe404881 (patch)
treee50ebf8e21a1bc67bec5e84dcb4ee054ddba6ec2 /dev-python/execnet/execnet-1.4.1.ebuild
parentdev-python/pytest-cache: Add pypy* support (diff)
downloadgentoo-a7e6cd2c880d2e40d6fbc36018e485f0fe404881.tar.gz
gentoo-a7e6cd2c880d2e40d6fbc36018e485f0fe404881.tar.bz2
gentoo-a7e6cd2c880d2e40d6fbc36018e485f0fe404881.zip
dev-python/execnet: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/execnet/execnet-1.4.1.ebuild')
-rw-r--r--dev-python/execnet/execnet-1.4.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/execnet/execnet-1.4.1.ebuild b/dev-python/execnet/execnet-1.4.1.ebuild
new file mode 100644
index 000000000000..7e5cad3119e4
--- /dev/null
+++ b/dev-python/execnet/execnet-1.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ https://pypi.python.org/pypi/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}