summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-01 12:11:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-01 14:19:19 +0200
commit27d69acc90dd3b17b848bbb92c5374ed2cb83b9f (patch)
tree0a2e59ae23983cb6bf2d19acfe39b462b31f592d /dev-python/flit
parentdev-python/pydyf: Tests need ghostscript (diff)
downloadgentoo-27d69acc90dd3b17b848bbb92c5374ed2cb83b9f.tar.gz
gentoo-27d69acc90dd3b17b848bbb92c5374ed2cb83b9f.tar.bz2
gentoo-27d69acc90dd3b17b848bbb92c5374ed2cb83b9f.zip
dev-python/flit: Revert "Bump to 3.3.0"
The commit accidentally included changes to 3.2.0. Reverts: 0ebeafe5cae26a6599da337f2a79af02904acd84 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest1
-rw-r--r--dev-python/flit/flit-3.2.0.ebuild15
-rw-r--r--dev-python/flit/flit-3.3.0.ebuild41
3 files changed, 11 insertions, 46 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index 84ed16c295b1..b98e888eed18 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,3 +1,2 @@
DIST flit-2.1.0.tar.gz 106459 BLAKE2B db51d8cc119ae8aa5f8d0ac1655cd29390065567391cbdf06ca7dbb98a79e96a6d8f318273c2f9a58aaf549090a903360701a844ac071d15304a21ea54052a91 SHA512 0fcbfaa1e5e83216a5c98cc87b0a8f2aa17e2c184ec3f09c7dd0dd5e695311be62344ac4f101cb71f87390513496f8c1152a2cd8d7363202f7696ee002f07a55
DIST flit-3.2.0.tar.gz 115192 BLAKE2B dda4b9f5b56b9868d737516841d7fc49c0e97ef8a71f9f0628112f68c3dadae89a87aef56cebfe8ec3762af5970d206fe462add146d52b3893fb8852fd7f9625 SHA512 1db7c4118fe1d70d1e318db3bc282747d6cc3f3b626ad68420fa056e585caad9ff0a3f230e17c919ea260ddeb6330effc4bbed8b30d11ed7b27e78d9d7af0445
-DIST flit-3.3.0.tar.gz 117809 BLAKE2B 8ad74f70406e41b35b44886b145b52d83fc30d0a1395bf711807da2ae3974ae8606113e4bcd556694854c48c8c01c3c03b4a1021c7cc3e33cce0e99a5abbb9ea SHA512 904889298aab581640e8323fd68c83d753ea97af0ed1b8f438f192d84d09ced83718440a03d23864885fcf966de9665c3046f0f3a1b1d4170b2decf8430ff006
diff --git a/dev-python/flit/flit-3.2.0.ebuild b/dev-python/flit/flit-3.2.0.ebuild
index 4ce07661eafa..289ae9807716 100644
--- a/dev-python/flit/flit-3.2.0.ebuild
+++ b/dev-python/flit/flit-3.2.0.ebuild
@@ -1,10 +1,9 @@
# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI=7
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Simplified packaging of Python modules"
@@ -14,6 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
RDEPEND="
>=dev-python/flit_core-3.2.0[${PYTHON_USEDEP}]
@@ -22,7 +22,7 @@ RDEPEND="
dev-python/requests_download[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
"
-BDEPEND="
+BDEPEND="${RDEPEND}
sys-apps/grep
sys-apps/findutils
test? (
@@ -39,3 +39,10 @@ distutils_enable_tests pytest
distutils_enable_sphinx doc \
dev-python/sphinxcontrib-github-alt \
dev-python/pygments-github-lexers \
+
+python_prepare_all() {
+ printf -- "from setuptools import setup, find_packages\nsetup(name='%s',version='%s',%s)" \
+ "${PN}" "${PV}" "packages=find_packages(exclude=['tests'])" > setup.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/flit/flit-3.3.0.ebuild b/dev-python/flit/flit-3.3.0.ebuild
deleted file mode 100644
index b7434f5ec52d..000000000000
--- a/dev-python/flit/flit-3.3.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Simplified packaging of Python modules"
-HOMEPAGE="https://github.com/takluyver/flit https://flit.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/flit_core-3.3.0[${PYTHON_USEDEP}]
- dev-python/intreehooks[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests_download[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- sys-apps/grep
- sys-apps/findutils
- test? (
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/flit-3.2.0-tests.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc \
- dev-python/sphinxcontrib-github-alt \
- dev-python/pygments-github-lexers \