summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 15:08:14 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 15:48:46 +0100
commitfdc56ab8a28d506fc8b279bd12572dd5fd0a1362 (patch)
treeac9cd03c2fed1bfcfec994aa2ecdea56339eb315 /dev-python/httpbin
parentdev-python/flask: Add pypy3 support (diff)
downloadgentoo-fdc56ab8a28d506fc8b279bd12572dd5fd0a1362.tar.gz
gentoo-fdc56ab8a28d506fc8b279bd12572dd5fd0a1362.tar.bz2
gentoo-fdc56ab8a28d506fc8b279bd12572dd5fd0a1362.zip
dev-python/httpbin: New package, ebuild written by me
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest1
-rw-r--r--dev-python/httpbin/httpbin-0.4.0.ebuild36
-rw-r--r--dev-python/httpbin/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
new file mode 100644
index 000000000000..32b446fab42d
--- /dev/null
+++ b/dev-python/httpbin/Manifest
@@ -0,0 +1 @@
+DIST httpbin-0.4.0.tar.gz 88000 SHA256 697e6ff51996699231782ec3519e936c57f34185d33dfadbe131536a6eced9b8 SHA512 ce239c7c2a7715dce340f04aab417b0c73773e9ff6b33edb81540abc63be9c861c4386d1310e9ae46dcdeeff24a6b71b7b93d9b2120cb1533e7da2c10f177830 WHIRLPOOL 11e9407ab88175212a66b4f47d9baeaa36ab281c5258f024e2375e5f7039fe013d246b2ac5f0a35da2a11a48e6fca91f9cdfee98cc36b21ad8cf89a57e8f7469
diff --git a/dev-python/httpbin/httpbin-0.4.0.ebuild b/dev-python/httpbin/httpbin-0.4.0.ebuild
new file mode 100644
index 000000000000..e80b3b2d95aa
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="https://github.com/Runscope/httpbin http://pypi.python.org/pypi/httpbin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/werkzeug[${PYTHON_USEDEP}] )"
+
+# Not included
+# Someone needs to file a bug upstream
+RESTRICT=test
+
+python_test() {
+ ${PYTHON} test_httpbin.py || die
+}
diff --git a/dev-python/httpbin/metadata.xml b/dev-python/httpbin/metadata.xml
new file mode 100644
index 000000000000..b3fab065a5e4
--- /dev/null
+++ b/dev-python/httpbin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">httpbin</remote-id>
+ <maintainer status="unknown">
+ <email>httpbin@runscope.com</email>
+ <name>Runscope</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>