summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-09-01 19:34:00 -0500
committerPatrice Clement <monsieurp@gentoo.org>2018-09-10 15:23:24 +0200
commit31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9 (patch)
treef77f379654a8f50c383bd94eb5cbabddadff79f5 /dev-python/ldap3/ldap3-2.5.1.ebuild
parentapp-editors/neovim: add missing dependency on libnsl. (diff)
downloadgentoo-31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9.tar.gz
gentoo-31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9.tar.bz2
gentoo-31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9.zip
dev-python/ldap3: version bump to 2.5.1.
Updating the package to latest upstream available. Closes: https://bugs.gentoo.org/665082 Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9764
Diffstat (limited to 'dev-python/ldap3/ldap3-2.5.1.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-2.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-2.5.1.ebuild b/dev-python/ldap3/ldap3-2.5.1.ebuild
new file mode 100644
index 000000000000..0b8cb7a8fa84
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v -s test || die
+}