summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-01-23 11:35:46 +0100
committerSam James <sam@gentoo.org>2021-01-24 13:29:18 +0000
commit898c7530b63c3119c598cd7596dfbef75cbecfd7 (patch)
tree6b4d93532553986f99497596cd7cb88611e96937 /dev-python/nuitka/nuitka-0.6.11.ebuild
parentdev-ml/ppx_typerep_conv: add ml maintainer (diff)
downloadgentoo-898c7530b63c3119c598cd7596dfbef75cbecfd7.tar.gz
gentoo-898c7530b63c3119c598cd7596dfbef75cbecfd7.tar.bz2
gentoo-898c7530b63c3119c598cd7596dfbef75cbecfd7.zip
dev-python/nuitka: bump version to 0.6.11
Also, added tests to the ebuild. Closes: https://bugs.gentoo.org/762730 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/nuitka/nuitka-0.6.11.ebuild')
-rw-r--r--dev-python/nuitka/nuitka-0.6.11.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/nuitka/nuitka-0.6.11.ebuild b/dev-python/nuitka/nuitka-0.6.11.ebuild
new file mode 100644
index 000000000000..c23425d68d01
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+
+RDEPEND="${BDEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+S="${WORKDIR}/${P^}"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}