summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-20 12:22:18 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-20 12:24:03 +0200
commit795cd3a02f7ee23a17c551af217eace5c64308cd (patch)
tree37439ccd3922d627693ebbc3b2d557c8c05552f1 /dev-python/numexpr
parentapp-misc/reptyr: Drop old (diff)
downloadgentoo-795cd3a02f7ee23a17c551af217eace5c64308cd.tar.gz
gentoo-795cd3a02f7ee23a17c551af217eace5c64308cd.tar.bz2
gentoo-795cd3a02f7ee23a17c551af217eace5c64308cd.zip
dev-python/numexpr: Clean old
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest2
-rw-r--r--dev-python/numexpr/numexpr-2.4.1.ebuild48
-rw-r--r--dev-python/numexpr/numexpr-2.4.ebuild48
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 4d021ca05c44..205b8dd93144 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,4 +1,2 @@
-DIST numexpr-2.4.1.tar.gz 84990 SHA256 5b53a9e9e50f33e2e562b4ae9f88066c9e54a3bd7c144d29d0067b87856815b4 SHA512 d5aa34532dd1a504b3c78cff07def4114201560c04ce30d033a4701eb95961c53582b71291569cd10f22d50b00edc5dbb4e1b6454d8597c68f231c9c576471b7 WHIRLPOOL 9bfde967bc772111e1cc4a8e5931dc31896b7da4b43c33b8ae7bb3701f782e895b434ee4cddabe2a90abfe90cc240322b92dc224b7917123d90f2d9f9044cea4
DIST numexpr-2.4.3.tar.gz 85171 SHA256 3ae7191c89df40db6b0a8637a4dace7c5956bc910793a53225f985f3b443c722 SHA512 b33984072fddd4303980be8533e1348b48ff27de5e150029147e3666ce6bb9e1147dbc45eb0ef22506aebaea6fb366d65ff01221235f9b9935d78ea70ba9aa53 WHIRLPOOL ac5981bac643b825d6ab2fbd6c46b6d73ad62374490e5f05a71fc0b9c4269ab401617da98079e1604b11f454863e64e009a2acc00b7b30499b20eff73efe033f
DIST numexpr-2.4.4.tar.gz 87133 SHA256 dfa2fad1af040e93a8022fbe4437f2183bf80e5f64d466381ad589308a73565b SHA512 abc53f8aafb39e55b6b811c1f08c01eefca23c36fb9d20a82484ef658c8062ffe51d8841d6651f43fb7f8cea6420270623df6ba9f98a95a0f7a09e6ceef91b35 WHIRLPOOL 9ab19609189e866a11c03b0aeaa3b93124d8018d53e8dec641721eff39eb73c969c34c457209d63988361ffadef13a205ba5b71d19ad120e9f44313f42c7cd1b
-DIST numexpr-2.4.tar.gz 84770 SHA256 1b63a5ce11c10d36433e2a74e2e4c360a4e004618507778881659e80a912fc58 SHA512 bebc3e81505f4c2e7d3c6f7cf2c02fe1ce07186c81de743db43399f2f81a135125a675dbd7a631fea55aaea1d092ab9a84539676027ce31f6fb7b1fca23cf253 WHIRLPOOL 1cf2e98f8e092505c1098f0c55a1b05488146164afa3bfec351cbe8ed44fa401edab503884ffa2b599a5a8db86e4bda94229a6d147aba60f554141ec85f37273
diff --git a/dev-python/numexpr/numexpr-2.4.1.ebuild b/dev-python/numexpr/numexpr-2.4.1.ebuild
deleted file mode 100644
index f115595836c5..000000000000
--- a/dev-python/numexpr/numexpr-2.4.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( ANNOUNCE.rst AUTHORS.txt README.rst RELEASE_NOTES.rst )
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- local ext
- use amd64 && ext=_lp64
- cat <<- EOF > "${S}"/site.cfg
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- EOF
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- "${PYTHON}" -c "import numexpr; numexpr.test()" || die
-}
diff --git a/dev-python/numexpr/numexpr-2.4.ebuild b/dev-python/numexpr/numexpr-2.4.ebuild
deleted file mode 100644
index 83c7c988eac9..000000000000
--- a/dev-python/numexpr/numexpr-2.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( ANNOUNCE.rst AUTHORS.txt README.rst RELEASE_NOTES.rst )
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- local ext
- use amd64 && ext=_lp64
- cat <<- EOF > "${S}"/site.cfg
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- EOF
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- "${PYTHON}" -c "import numexpr; numexpr.test()" || die
-}