summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 21:30:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 22:26:04 -0600
commit68037f22f8df6fc7e1b0183f30e7d05cad115acd (patch)
tree53406148c8da96a5c9dfa45887de37ba105ea27b /dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild
parentdev-python/oslo-reports: bup (diff)
downloadgentoo-68037f22f8df6fc7e1b0183f30e7d05cad115acd.tar.gz
gentoo-68037f22f8df6fc7e1b0183f30e7d05cad115acd.tar.bz2
gentoo-68037f22f8df6fc7e1b0183f30e7d05cad115acd.zip
dev-python/oslo-rootwrap: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild')
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild
new file mode 100644
index 000000000000..42e6fb2940bd
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}