summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-18 09:15:55 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-18 09:16:24 +0000
commit7dc3315bb017ceed89254dc9eaea6ce1059d823f (patch)
treeaf32ef75f33867dceeb27ad5591d3fb3d6e3f179 /dev-python/peewee
parentMerge remote-tracking branch 'github/pr/871'. (diff)
downloadgentoo-7dc3315bb017ceed89254dc9eaea6ce1059d823f.tar.gz
gentoo-7dc3315bb017ceed89254dc9eaea6ce1059d823f.tar.bz2
gentoo-7dc3315bb017ceed89254dc9eaea6ce1059d823f.zip
dev-python/peewee: Fix two errors.
* sed to remove the string "test_suite='tests'" from setup.py. * Add -fno-strict-aliasing compile flag when compiling with python2.7. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/peewee-2.8.0.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-2.8.0.ebuild b/dev-python/peewee/peewee-2.8.0.ebuild
index 3d9a37b6d686..aacf223e06a0 100644
--- a/dev-python/peewee/peewee-2.8.0.ebuild
+++ b/dev-python/peewee/peewee-2.8.0.ebuild
@@ -22,6 +22,16 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
DISTUTILS_IN_SOURCE_BUILD=1
+python_prepare_all() {
+ sed -i -e "s#test_suite='tests',##g;" ./setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
python_compile_all() {
use doc && emake -C docs html
}