summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 10:00:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 10:51:33 +0100
commitc0ea49679d3d8273d3f2b5ccd5937100860f8cad (patch)
tree2b79238bb03a4f5363d417b89c832009847e2385 /dev-python/precis-i18n/precis-i18n-1.0.4.ebuild
parentdev-python/cli_helpers: Bump to 2.2.1 (diff)
downloadgentoo-c0ea49679d3d8273d3f2b5ccd5937100860f8cad.tar.gz
gentoo-c0ea49679d3d8273d3f2b5ccd5937100860f8cad.tar.bz2
gentoo-c0ea49679d3d8273d3f2b5ccd5937100860f8cad.zip
dev-python/precis-i18n: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/precis-i18n/precis-i18n-1.0.4.ebuild')
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.4.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.4.ebuild
new file mode 100644
index 000000000000..68dc8485e8b5
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.org/project/precis-i18n/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}