summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-01 08:46:17 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-01 08:47:51 +0100
commit5079b5bcc0ab71b4bb5a228aede0b34bd9bbc710 (patch)
treeadfc6baa44f79b170b3e63b5d6407c9205c277e0 /dev-python/pycryptodome
parentdev-python/paramiko: add py36 support (diff)
downloadgentoo-5079b5bcc0ab71b4bb5a228aede0b34bd9bbc710.tar.gz
gentoo-5079b5bcc0ab71b4bb5a228aede0b34bd9bbc710.tar.bz2
gentoo-5079b5bcc0ab71b4bb5a228aede0b34bd9bbc710.zip
dev-python/pycryptodome: Initial commit, #602022
Initial commit for dev-python/pycrypto fork and partially drop-in replacement. Let's start with a simple, separate package and see how it works out for us.
Diffstat (limited to 'dev-python/pycryptodome')
-rw-r--r--dev-python/pycryptodome/Manifest1
-rw-r--r--dev-python/pycryptodome/metadata.xml8
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.4.5.ebuild28
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
new file mode 100644
index 000000000000..8cee92c95ea3
--- /dev/null
+++ b/dev-python/pycryptodome/Manifest
@@ -0,0 +1 @@
+DIST pycryptodome-3.4.5.tar.gz 6968315 SHA256 356740c25bee66cf02fce496154f2b9699e5c75c1c6c7e382064d8b6c2cac2dd SHA512 666a90e0cd756b26212df29b2d88c7443bd12fcbf0db6afc6e251a4e92a8528d82495528610c834cd6c066eb384a83f075cb49d52c60c65af04c0e5ff3ce72f8 WHIRLPOOL 41f5d5f64eae7de88b8a6a86f6868a90e3b9eb73f3747cc8e95eb2f30225c3db5ec3b75c9cf92f3542069f3773a0f12a511b113d02046b22473559180d764c03
diff --git a/dev-python/pycryptodome/metadata.xml b/dev-python/pycryptodome/metadata.xml
new file mode 100644
index 000000000000..904952d1b58a
--- /dev/null
+++ b/dev-python/pycryptodome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>python@gentoo.org</email>
+ <name>Python project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pycryptodome/pycryptodome-3.4.5.ebuild b/dev-python/pycryptodome/pycryptodome-3.4.5.ebuild
new file mode 100644
index 000000000000..d6eebef2a142
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.4.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://github.com/Legrandin/pycryptodome"
+SRC_URI="https://github.com/Legrandin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/gmp:0
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ !dev-python/pycrypto"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}