summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-16 16:44:21 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-16 16:44:41 +0200
commit266c29b87d900ec267a8d5fe2113e516c0c2ad1a (patch)
treebc0bb7f68fab6017b2ef240d4e2bf9f9d551836a /dev-python/pylint
parentmedia-libs/libsamplerate: Cleaning up vulnerable versions for CVE-2017-7697 a... (diff)
downloadgentoo-266c29b87d900ec267a8d5fe2113e516c0c2ad1a.tar.gz
gentoo-266c29b87d900ec267a8d5fe2113e516c0c2ad1a.tar.bz2
gentoo-266c29b87d900ec267a8d5fe2113e516c0c2ad1a.zip
dev-python/pylint: Version bump to 1.7.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-1.7.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 047cf531472d..83032cbf884f 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,4 @@
DIST pylint-1.4.4.tar.gz 342461 SHA256 0561af4d6bd4fa9e8e02f3997fe93684f7187c57bcef9db8c2ea9fb0d7d2f022 SHA512 bcbf5439628a071055cea441455f6c0fe0cbfae2617c473bc376b880421f17f78653901d7cf49950653436a0991a3bafbc2df15744ff24a3b059de53e518b331 WHIRLPOOL 9b8f5384691f5e762bfd7313691783e0b1a9148effec0b29f2e538f587dfa03f57413817589f8fc3f152c05330b7f39c8ede27720ff6ad12496f9101d824fedf
DIST pylint-1.5.6.tar.gz 425251 SHA256 303bdd755048feec2c1fe1ea16e8f4306636f02845510ff3d5922ae2d6fe35cc SHA512 569a747a0d2c4f60ff2c16af6117f501fa1a9a6546fcc1228909b23024e2bc05951985acf56249919b67b11f161cb1855321115ad9fd7a7c409b71faa5dd8278 WHIRLPOOL 286e32ae39dfc3ce8d13efb9e9acec98db698f742bf399ccd6d7e053a2bdb1b7ea30b36a10a65fa4867bb6316da08c1181c5f0f0f39b0a920ddc3cf60e85f462
DIST pylint-1.6.5.tar.gz 465578 SHA256 a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719 SHA512 2fac352dc752b37f1ce4f7fefe5afbbc880d7e6c38f164d1c50734716af1dd6fe31f7d41e145a8256837d5a63b1989efec40c169fc14840cf8eb4e18d9bb2410 WHIRLPOOL 55201c238f9a6ba473d038ea1739bfb9b1e8183685bf5630405d436df1a0843642a354af698d1b585752c53e270fc4bd2d4d56d509c5d7acf5271a8fd1447eb3
+DIST pylint-1.7.1.tar.gz 489108 SHA256 8b4a7ab6cf5062e40e2763c0b4a596020abada1d7304e369578b522e46a6264a SHA512 e0efbaad3ca3205a2e2e1e4bc444e635540db12e139e008ff2ca8b454dd117488e767f070126074389d6d82c17622da747b9a948711225246877fed69ac81148 WHIRLPOOL 0f041bce357b68d2bd48fd51d6dc3cf7336a51160cf96771bfea059835e9ee1f535d0a19fc5876308040d5d16ef113b464a90b21d4109f11a77ef65da29425a5
diff --git a/dev-python/pylint/pylint-1.7.1.ebuild b/dev-python/pylint/pylint-1.7.1.ebuild
new file mode 100644
index 000000000000..1c5b2098c547
--- /dev/null
+++ b/dev-python/pylint/pylint-1.7.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ http://www.logilab.org/project/pylint
+ https://pypi.python.org/pypi/pylint
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/astroid-1.5.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ dev-python/mccabe
+ $(python_gen_cond_dep '
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ dev-python/configparser[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+RESTRICT="test" # multiple failures
+
+# Usual. Requ'd for impl specific failures in test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
+}
+
+python_test() {
+ ${EPYTHON} \
+ -m unittest discover \
+ -s pylint/test/ -p "*test_*".py \
+ --verbose || die
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+ use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
+}