summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-13 14:00:47 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-13 14:11:04 +0100
commitb8a5618abcfdc0770aae702186affa1649ef9afb (patch)
treef0b64325596525aaba5c0383dd31513c919e71f6 /dev-python/pyopencl
parentapp-forensics/honggfuzz: update HOMEPAGE, EAPI 7 -> 8 (diff)
downloadgentoo-b8a5618abcfdc0770aae702186affa1649ef9afb.tar.gz
gentoo-b8a5618abcfdc0770aae702186affa1649ef9afb.tar.bz2
gentoo-b8a5618abcfdc0770aae702186affa1649ef9afb.zip
dev-python/pyopencl: drop 2021.2.3 and 2021.2.5, add 2021.2.6
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest3
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.3.ebuild57
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.6.ebuild (renamed from dev-python/pyopencl/pyopencl-2021.2.5.ebuild)0
3 files changed, 1 insertions, 59 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 6e103b991954..f74a74ce907e 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,2 @@
DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
-DIST pyopencl-2021.2.3.tar.gz 450895 BLAKE2B 0395ee6ef32baa57fe9df0c9960f5d761cfced1cc8b87e51e7ebcc7cda6a6b651fc491acf6be525239576fedec2a8375935799fc77568e131dcb26436a59c6f1 SHA512 41ef44eac0112ceac15c1260198a0bd642c244f3ad45aa1d7feba70b55a3f257ce01f7c5a8eaf2ce1df263492452055286caad004101d8bdb2d4f7307fb339be
-DIST pyopencl-2021.2.5.tar.gz 449527 BLAKE2B 922970c6aa93d2ce600c1e107fa3303c42bd44a264f7c38b30c8d2c909ec12e4cf8fa21dbaffa558c7b183141802ac13fe1a1032230b611b56503cfbaeae40c1 SHA512 a8784e0c6ae9a3c2d8f463405d5bbfe4ac1df138fd5f1ca8ce622afaab787333574c6ee8f4a828c09dc36c1b7a5df8fbe5d70e2236be32d457c3e1cbdeb880e5
+DIST pyopencl-2021.2.6.tar.gz 450194 BLAKE2B be9d0bf653f77d33a4337deab9189a5a9031ff50526444283c6fb9f8625d0451cb211ff703b5eb86c18beebb973f8f7a7cc93da3efc6bb4e95cd533d633fde93 SHA512 b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c
diff --git a/dev-python/pyopencl/pyopencl-2021.2.3.ebuild b/dev-python/pyopencl/pyopencl-2021.2.3.ebuild
deleted file mode 100644
index 32a5237b3e9e..000000000000
--- a/dev-python/pyopencl/pyopencl-2021.2.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples opengl"
-
-COMMON="dev-python/numpy[${PYTHON_USEDEP}]
- >=virtual/opencl-2"
-RDEPEND="${COMMON}
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]
- opengl? ( media-libs/libglvnd )"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopencl/pyopencl-2021.2.5.ebuild b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
index 9c4b6ac92a78..9c4b6ac92a78 100644
--- a/dev-python/pyopencl/pyopencl-2021.2.5.ebuild
+++ b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild