summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-14 08:34:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-14 10:59:05 +0200
commit6eeb1f7c106f6c39fefee7216a908d37ea9e4336 (patch)
treec429ed2edfa082c37396bc87550e202a82c0924b /dev-python/pypy
parentdev-python/ipywidgets: Bump to 7.6.5 (diff)
downloadgentoo-6eeb1f7c106f6c39fefee7216a908d37ea9e4336.tar.gz
gentoo-6eeb1f7c106f6c39fefee7216a908d37ea9e4336.tar.bz2
gentoo-6eeb1f7c106f6c39fefee7216a908d37ea9e4336.zip
dev-python/pypy: Add a subslot check
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy')
-rw-r--r--dev-python/pypy/pypy-7.3.6_rc1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pypy/pypy-7.3.6_rc1.ebuild b/dev-python/pypy/pypy-7.3.6_rc1.ebuild
index d4372953f882..c4b76dcdef06 100644
--- a/dev-python/pypy/pypy-7.3.6_rc1.ebuild
+++ b/dev-python/pypy/pypy-7.3.6_rc1.ebuild
@@ -56,6 +56,10 @@ src_compile() {
mv pypy/module/cpyext/parse/*.h include/ || die
pax-mark m pypy-c
+ # verify the subslot
+ local soabi=$(./pypy-c -c 'import sysconfig; print sysconfig.get_config_var("SOABI")')
+ [[ ${soabi#pypy-} == ${SLOT#*/} ]] || die "update subslot to ${soabi}"
+
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.