summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 21:38:18 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 21:38:18 +0200
commitf5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd (patch)
treeb330b7ba50a915e73eac48ded38ab42e7bdf76a9 /dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
parentapp-crypt/acme: Sync live (diff)
downloadgentoo-f5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd.tar.gz
gentoo-f5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd.tar.bz2
gentoo-f5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd.zip
dev-python/pytest-mock: Version bump to 1.6.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-1.6.0.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild b/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
new file mode 100644
index 000000000000..32941be25b3c
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/mock[python_targets_python2_7]
+ )
+ python_targets_pypy? (
+ dev-python/mock[python_targets_pypy]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test test_pytest_mock.py || die
+}