summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2016-06-06 09:14:56 +0200
committerCédric Krier <cedk@gentoo.org>2016-06-06 09:16:47 +0200
commit0d68f251903ef9555fded9039a0fe8e58ae89b60 (patch)
tree6c53340dc39fb6a60e2256ef036dc5e0a99af5c8 /dev-python/python-stdnum/python-stdnum-1.3.ebuild
parentmedia-sound/cantata: Remove 2.0.0 (diff)
downloadgentoo-0d68f251903ef9555fded9039a0fe8e58ae89b60.tar.gz
gentoo-0d68f251903ef9555fded9039a0fe8e58ae89b60.tar.bz2
gentoo-0d68f251903ef9555fded9039a0fe8e58ae89b60.zip
dev-python/python-stdnum: version bump to 1.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.3.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.3.ebuild b/dev-python/python-stdnum/python-stdnum-1.3.ebuild
new file mode 100644
index 000000000000..1ce3022a320c
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}