summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-24 14:15:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-24 16:31:29 +0200
commit55d5dbf03ec30a970bc7cb7f19448b75e66e91af (patch)
tree7c729957c87814521eb1cd403a1516c0870cc905 /dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild
parentdev-python/tblib: Bump to 1.7.0 (diff)
downloadgentoo-55d5dbf03ec30a970bc7cb7f19448b75e66e91af.tar.gz
gentoo-55d5dbf03ec30a970bc7cb7f19448b75e66e91af.tar.bz2
gentoo-55d5dbf03ec30a970bc7cb7f19448b75e66e91af.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild')
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild
new file mode 100644
index 000000000000..e8bb844066b9
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+PDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest