summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 13:59:24 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 16:11:41 +0100
commit3f0d79b8bbe71a84b1d08620911625216baffbb5 (patch)
treeef88a775ee1dc22af73a231dd633f27fafd0f4c0 /dev-python/seaborn/seaborn-0.7.0.ebuild
parentdev-python/pytest-catchlog: Version Bump (diff)
downloadgentoo-3f0d79b8bbe71a84b1d08620911625216baffbb5.tar.gz
gentoo-3f0d79b8bbe71a84b1d08620911625216baffbb5.tar.bz2
gentoo-3f0d79b8bbe71a84b1d08620911625216baffbb5.zip
dev-python/seaborn: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/seaborn/seaborn-0.7.0.ebuild')
-rw-r--r--dev-python/seaborn/seaborn-0.7.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/seaborn/seaborn-0.7.0.ebuild b/dev-python/seaborn/seaborn-0.7.0.ebuild
new file mode 100644
index 000000000000..dc414e346455
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/ https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+# https://github.com/mwaskom/seaborn/issues/836
+RESTRICT=test
+
+python_test() {
+ virtx nosetests --verbosity=3
+}