summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-10-07 09:46:09 -0400
committerMike Gilbert <floppym@gentoo.org>2018-10-07 09:46:09 -0400
commit9762d3f55df73a6cefd1b2885d9d875343e440f3 (patch)
tree4a4c557c934531bf4f7e50c6d368c9d968884522 /dev-python/sip
parentx11-libs/libnotify: replace prune_libtool_files (diff)
downloadgentoo-9762d3f55df73a6cefd1b2885d9d875343e440f3.tar.gz
gentoo-9762d3f55df73a6cefd1b2885d9d875343e440f3.tar.bz2
gentoo-9762d3f55df73a6cefd1b2885d9d875343e440f3.zip
dev-python/sip: add -fno-strict-aliasing for python2
Package-Manager: Portage-2.3.50_p14, Repoman-2.3.11_p21 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/sip-4.19.12.ebuild6
-rw-r--r--dev-python/sip/sip-4.19.13.ebuild4
-rw-r--r--dev-python/sip/sip-4.19.8.ebuild6
-rw-r--r--dev-python/sip/sip-4.9999.ebuild6
4 files changed, 19 insertions, 3 deletions
diff --git a/dev-python/sip/sip-4.19.12.ebuild b/dev-python/sip/sip-4.19.12.ebuild
index 6707912b3761..3313a4fac4da 100644
--- a/dev-python/sip/sip-4.19.12.ebuild
+++ b/dev-python/sip/sip-4.19.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
src_configure() {
configuration() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
local myconf=(
"${PYTHON}"
"${S}"/configure.py
diff --git a/dev-python/sip/sip-4.19.13.ebuild b/dev-python/sip/sip-4.19.13.ebuild
index 728a604c424b..3313a4fac4da 100644
--- a/dev-python/sip/sip-4.19.13.ebuild
+++ b/dev-python/sip/sip-4.19.13.ebuild
@@ -69,6 +69,10 @@ src_prepare() {
src_configure() {
configuration() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
local myconf=(
"${PYTHON}"
"${S}"/configure.py
diff --git a/dev-python/sip/sip-4.19.8.ebuild b/dev-python/sip/sip-4.19.8.ebuild
index 973f1ae60a02..bd65f8202bbf 100644
--- a/dev-python/sip/sip-4.19.8.ebuild
+++ b/dev-python/sip/sip-4.19.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
src_configure() {
configuration() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
local myconf=(
"${PYTHON}"
"${S}"/configure.py
diff --git a/dev-python/sip/sip-4.9999.ebuild b/dev-python/sip/sip-4.9999.ebuild
index 3fe2c1981bd0..4df03eb6f4e8 100644
--- a/dev-python/sip/sip-4.9999.ebuild
+++ b/dev-python/sip/sip-4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
src_configure() {
configuration() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
local myconf=(
"${PYTHON}"
"${S}"/configure.py