summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/soya/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/soya/files')
-rw-r--r--dev-python/soya/files/soya-0.14-freetype-2.5.patch16
-rw-r--r--dev-python/soya/files/soya-0.14-glu.patch13
-rw-r--r--dev-python/soya/files/soya-pillow.patch21
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/soya/files/soya-0.14-freetype-2.5.patch b/dev-python/soya/files/soya-0.14-freetype-2.5.patch
new file mode 100644
index 000000000000..a4d568033109
--- /dev/null
+++ b/dev-python/soya/files/soya-0.14-freetype-2.5.patch
@@ -0,0 +1,16 @@
+diff -ru soya.old/include_freetype.h soya/include_freetype.h
+--- soya.old/include_freetype.h 2014-06-01 23:27:17.970830047 +0900
++++ soya/include_freetype.h 2014-06-01 23:27:35.320864678 +0900
+@@ -21,8 +21,8 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H // this is not do-able in Pyrex
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ftimage.h>
+-#include <freetype/ftglyph.h>
++#include <freetype.h>
++#include <ftoutln.h>
++#include <ftimage.h>
++#include <ftglyph.h>
+
diff --git a/dev-python/soya/files/soya-0.14-glu.patch b/dev-python/soya/files/soya-0.14-glu.patch
new file mode 100644
index 000000000000..606114a22fb7
--- /dev/null
+++ b/dev-python/soya/files/soya-0.14-glu.patch
@@ -0,0 +1,13 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 550)
++++ setup.py (working copy)
+@@ -130,7 +130,7 @@
+ if sys.platform[:3] == "win":
+ LIBS = ["m", "glew32", "SDL", "SDL_mixer", "freetype", "cal3d", "stdc++", "ode"]
+ else:
+- LIBS = ["m", "GLEW", "SDL", "freetype", "cal3d", "stdc++","ode"]
++ LIBS = ["m", "GLEW", "GLU" , "SDL", "freetype", "cal3d", "stdc++","ode"]
+ FRAMEWORKS=[]
+
+ SOYA_PYREX_SOURCES = ["_soya.pyx", "matrix.c", "chunk.c"]
diff --git a/dev-python/soya/files/soya-pillow.patch b/dev-python/soya/files/soya-pillow.patch
new file mode 100644
index 000000000000..4f8df982ccf2
--- /dev/null
+++ b/dev-python/soya/files/soya-pillow.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/show_bug.cgi?id=471510
+--- a/editor/__init__.py
++++ b/editor/__init__.py
+@@ -52,7 +52,7 @@
+
+ if obj.face.material and obj.face.material.texture:
+ try:
+- import Image, ImageTk
++ from PIL import Image, ImageTk
+
+ self.image = Image.open(os.path.join(soya.path[0], obj.face.material.texture.filename))
+
+@@ -71,7 +71,7 @@
+ self.cancel = self.master.cancel
+
+ def label_conf(self, event = None):
+- import Image, ImageTk
++ from PIL import Image, ImageTk
+
+ if self.image_width != self.label.winfo_width():
+ self.image_width = self.label.winfo_width()