summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/soya/files')
-rw-r--r--dev-python/soya/files/soya-0.14-freetype-2.5.patch16
-rw-r--r--dev-python/soya/files/soya-0.14-glu.patch13
-rw-r--r--dev-python/soya/files/soya-pillow.patch21
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/soya/files/soya-0.14-freetype-2.5.patch b/dev-python/soya/files/soya-0.14-freetype-2.5.patch
new file mode 100644
index 000000000000..a4d568033109
--- /dev/null
+++ b/dev-python/soya/files/soya-0.14-freetype-2.5.patch
@@ -0,0 +1,16 @@
+diff -ru soya.old/include_freetype.h soya/include_freetype.h
+--- soya.old/include_freetype.h 2014-06-01 23:27:17.970830047 +0900
++++ soya/include_freetype.h 2014-06-01 23:27:35.320864678 +0900
+@@ -21,8 +21,8 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H // this is not do-able in Pyrex
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ftimage.h>
+-#include <freetype/ftglyph.h>
++#include <freetype.h>
++#include <ftoutln.h>
++#include <ftimage.h>
++#include <ftglyph.h>
+
diff --git a/dev-python/soya/files/soya-0.14-glu.patch b/dev-python/soya/files/soya-0.14-glu.patch
new file mode 100644
index 000000000000..606114a22fb7
--- /dev/null
+++ b/dev-python/soya/files/soya-0.14-glu.patch
@@ -0,0 +1,13 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 550)
++++ setup.py (working copy)
+@@ -130,7 +130,7 @@
+ if sys.platform[:3] == "win":
+ LIBS = ["m", "glew32", "SDL", "SDL_mixer", "freetype", "cal3d", "stdc++", "ode"]
+ else:
+- LIBS = ["m", "GLEW", "SDL", "freetype", "cal3d", "stdc++","ode"]
++ LIBS = ["m", "GLEW", "GLU" , "SDL", "freetype", "cal3d", "stdc++","ode"]
+ FRAMEWORKS=[]
+
+ SOYA_PYREX_SOURCES = ["_soya.pyx", "matrix.c", "chunk.c"]
diff --git a/dev-python/soya/files/soya-pillow.patch b/dev-python/soya/files/soya-pillow.patch
new file mode 100644
index 000000000000..4f8df982ccf2
--- /dev/null
+++ b/dev-python/soya/files/soya-pillow.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/show_bug.cgi?id=471510
+--- a/editor/__init__.py
++++ b/editor/__init__.py
+@@ -52,7 +52,7 @@
+
+ if obj.face.material and obj.face.material.texture:
+ try:
+- import Image, ImageTk
++ from PIL import Image, ImageTk
+
+ self.image = Image.open(os.path.join(soya.path[0], obj.face.material.texture.filename))
+
+@@ -71,7 +71,7 @@
+ self.cancel = self.master.cancel
+
+ def label_conf(self, event = None):
+- import Image, ImageTk
++ from PIL import Image, ImageTk
+
+ if self.image_width != self.label.winfo_width():
+ self.image_width = self.label.winfo_width()