summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 12:06:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 12:07:00 +0200
commit2789272306f626ebce22604d0e741724f6f522e7 (patch)
tree6318e4fed059bb5b7efc175779b625321f39c544 /dev-python
parentdev-python/cssselect: Drop pypy support again due to unsatified deps (diff)
downloadgentoo-2789272306f626ebce22604d0e741724f6f522e7.tar.gz
gentoo-2789272306f626ebce22604d0e741724f6f522e7.tar.bz2
gentoo-2789272306f626ebce22604d0e741724f6f522e7.zip
dev-python/pyquery: Drop optional dep to optfeature
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyquery/Manifest1
-rw-r--r--dev-python/pyquery/metadata.xml3
-rw-r--r--dev-python/pyquery/pyquery-1.2.4.ebuild44
-rw-r--r--dev-python/pyquery/pyquery-1.2.8.ebuild17
-rw-r--r--dev-python/pyquery/pyquery-1.2.9-r1.ebuild15
-rw-r--r--dev-python/pyquery/pyquery-1.2.9.ebuild15
6 files changed, 31 insertions, 64 deletions
diff --git a/dev-python/pyquery/Manifest b/dev-python/pyquery/Manifest
index 739b3fdfae52..91ab6dcb27b5 100644
--- a/dev-python/pyquery/Manifest
+++ b/dev-python/pyquery/Manifest
@@ -1,3 +1,2 @@
-DIST pyquery-1.2.4.tar.gz 23999 SHA256 1c39f786c42430279eadf787f1ef06873f15c9acba2698c23dfd925ac7b169d7 SHA512 77ec2efab157f693361e1dcbeabd7cac0709d3a8a25b6c47eb333be49c1485c7fa50b4fd9238bfff69657368130c2886cf6e0705415bdf1b48dc434365539c29 WHIRLPOOL 3fece4f710d69a0b57ab858f759196b269984a38af568003f7280215763c67b1e229feaf80f27b359a5da923248a11335026af4de85806ea6fc969c61c197685
DIST pyquery-1.2.8.zip 42552 SHA256 59af39301bad397e085e5080987f94ef30672f1cf8e73d19d3307b3b63c3cb4b SHA512 9d344a5c4b0dd565e31c803ceecb217c71f9a70badbc65f9fcfb4a2cccb725a1bf938ed0b1697dcfdf0ec967321dccc1916a884ffdb0af9828a65005f63c47d7 WHIRLPOOL 5c98c3e7584d429a7c9bca564aac04e5dc6f579265aa9b8b768e167cdfcc57758b0d728b3102a56af75fa6ea838a6c1927e733a5171d3266574ba2b34ee85209
DIST pyquery-1.2.9.zip 45289 SHA256 46c51eb878b787e814ee8f9737b0a62111034aeb4d1c06450ac5a8ea5a70e602 SHA512 f5152b471c896b39032add6a7f0e6ce63f426b4903bc7cf9eef12723c73453b40c310dd1497a7c4189fc6faaf804690fd91fb6d2f97fb6c4d6314682de4b8d05 WHIRLPOOL a57bb04402a3a8af98e7073d2b4e415a3e455bb67b4dc946831832f24339fe29fcd560123651abb3ae38c4ee9da3973638d27e064122702c0d1dd63d971fb67b
diff --git a/dev-python/pyquery/metadata.xml b/dev-python/pyquery/metadata.xml
index 5609388fe1aa..a606518ddfc6 100644
--- a/dev-python/pyquery/metadata.xml
+++ b/dev-python/pyquery/metadata.xml
@@ -6,7 +6,4 @@
<remote-id type="pypi">pyquery</remote-id>
<remote-id type="github">gawel/pyquery</remote-id>
</upstream>
- <use>
- <flag name="beautifulsoup3">Support BeautifulSoup 3</flag>
- </use>
</pkgmetadata>
diff --git a/dev-python/pyquery/pyquery-1.2.4.ebuild b/dev-python/pyquery/pyquery-1.2.4.ebuild
deleted file mode 100644
index 21a1e0d5de20..000000000000
--- a/dev-python/pyquery/pyquery-1.2.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="A jQuery-like library for python"
-HOMEPAGE="https://pypi.python.org/pypi/pyquery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="beautifulsoup3 test"
-
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- >=dev-python/webob-1.2_rc1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
-DOCS=( CHANGES.rst README.rst )
-
-python_prepare_all() {
- # Disable tests that access the net
- for file in docs/{ajax.txt,manipulating.txt,scrap.txt,tips.txt}
- do
- mv ${file} ${file/.txt/} || die
- done
- sed -e 's:>>> d = pq(url:>>> # d = pq(url:' -i README.rst || die
- sed -e 's:class TestWebScrapping:class _TestWebScrapping:' -i ${PN}/test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pyquery/pyquery-1.2.8.ebuild b/dev-python/pyquery/pyquery-1.2.8.ebuild
index fa371b17d203..4a02d400e46d 100644
--- a/dev-python/pyquery/pyquery-1.2.8.ebuild
+++ b/dev-python/pyquery/pyquery-1.2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="A jQuery-like library for python"
HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,9 +15,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="beautifulsoup3 test"
+IUSE="test"
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
dev-python/cssselect[${PYTHON_USEDEP}]
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]"
@@ -25,10 +26,10 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip
test? ( ${RDEPEND}
+ dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+ dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
dev-python/nose[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
python_prepare_all() {
# rm known failing tests and tests dependent on restkit
# https://github.com/gawel/pyquery/pull/63/files
@@ -43,3 +44,7 @@ python_test() {
# The suite, it appears, requires this hard setting of PYTHONPATH!
PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}
diff --git a/dev-python/pyquery/pyquery-1.2.9-r1.ebuild b/dev-python/pyquery/pyquery-1.2.9-r1.ebuild
index 1344a4c73808..580a69588fad 100644
--- a/dev-python/pyquery/pyquery-1.2.9-r1.ebuild
+++ b/dev-python/pyquery/pyquery-1.2.9-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="A jQuery-like library for python"
HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,23 +15,28 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="beautifulsoup3 test"
+IUSE="test"
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
>dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
>=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip
test? ( ${RDEPEND}
+ dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+ dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7') )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
python_test() {
# The suite, it appears, requires this hard setting of PYTHONPATH!
PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}
diff --git a/dev-python/pyquery/pyquery-1.2.9.ebuild b/dev-python/pyquery/pyquery-1.2.9.ebuild
index c556f77aa4a5..c738f3ac3d21 100644
--- a/dev-python/pyquery/pyquery-1.2.9.ebuild
+++ b/dev-python/pyquery/pyquery-1.2.9.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="A jQuery-like library for python"
HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,22 +15,27 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm ~hppa ppc ppc64 sparc x86"
-IUSE="beautifulsoup3 test"
+IUSE="test"
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
>dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
>=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip
test? ( ${RDEPEND}
+ dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+ dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
python_test() {
# The suite, it appears, requires this hard setting of PYTHONPATH!
PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}