summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 17:12:40 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 17:28:14 +0100
commit378ccfd5dad89a85441c70e5af4d9fa8c652e8ac (patch)
tree65171c76ccbd1be3f02a747deb28d17f58b328da /dev-python
parentdev-python/rednose: Add python3.5 support (diff)
downloadgentoo-378ccfd5dad89a85441c70e5af4d9fa8c652e8ac.tar.gz
gentoo-378ccfd5dad89a85441c70e5af4d9fa8c652e8ac.tar.bz2
gentoo-378ccfd5dad89a85441c70e5af4d9fa8c652e8ac.zip
dev-python/sure: Add python3.5 support and fix QA issues
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sure/sure-1.2.5-r1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/sure/sure-1.2.5-r1.ebuild b/dev-python/sure/sure-1.2.5-r1.ebuild
index 177d280f386d..dbb9ff4e1255 100644
--- a/dev-python/sure/sure-1.2.5-r1.ebuild
+++ b/dev-python/sure/sure-1.2.5-r1.ebuild
@@ -3,16 +3,15 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1 vcs-snapshot
-DESCRIPTION="utility belt for automated testing in python for python"
+DESCRIPTION="Utility belt for automated testing in python for python"
HOMEPAGE="https://github.com/gabrielfalcao/sure"
SRC_URI="https://github.com/gabrielfalcao/${PN}/archive/${PV}.tar.gz -> ${P}-r1.tar.gz"
-S="${WORKDIR}/${P}-r1"
-
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
@@ -28,15 +27,12 @@ DEPEND="
"
RDEPEND="${CDEPEND}"
+S="${WORKDIR}/${P}-r1"
+
python_prepare_all() {
- ebegin 'patching setup.py'
sed \
-e "82s/read_version()/'${PV}'/" \
- -i setup.py
- STATUS=$?
- eend ${STATUS}
- [[ ${STATUS} -gt 0 ]] && die
-
+ -i setup.py || die
distutils-r1_python_prepare_all
}