summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 18:26:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 20:29:10 -0500
commit5501fcb5b51a67497a1ded29ff82c343bbe47c0f (patch)
treee17dac096f2ec521b3cc5b1cc0799cd8c3da008a /dev-python
parentdev-python/joblib: bump to 0.17.0, add Python 3.9 support (diff)
downloadgentoo-5501fcb5b51a67497a1ded29ff82c343bbe47c0f.tar.gz
gentoo-5501fcb5b51a67497a1ded29ff82c343bbe47c0f.tar.bz2
gentoo-5501fcb5b51a67497a1ded29ff82c343bbe47c0f.zip
dev-python/debtcollector: 2.2.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-2.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 9a85edd7f340..7040aeb438af 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1 +1,2 @@
DIST debtcollector-1.21.0.tar.gz 28472 BLAKE2B a7c4a2d41ff6df1df1bfc2b775d888c1f9839ddb76bc80ff6b9bb9d1fb8e14eb225006021a0889d2a49c317c48f65cec024ff1d3c4e9c9bee1c0139a7cd1fc71 SHA512 a5a4f66a4d65134e84164de6953d4c6d5b2b9d36974055d26263b6d8505c4a131d693c371287ccd9c76220a9b59d6c3d1f0015db1d0f2bd8eafcb79c0bef0822
+DIST debtcollector-2.2.0.tar.gz 28833 BLAKE2B 33361daaba12c52a1cc0bac168199ef3dbb959279def29ef782fa421f0aa106038de02217f6321c64e02845abd0573e69f5638b384411e7fbfd194dd3f6b3356 SHA512 6e5fdf38a25406a7a56d18e9b900471e3e4ce513ef62619c9eafa153ea08ff6b4b9bd90c524cfa16e04ff0c9c324e90d4fdd75212fced0b202245cdddae02137
diff --git a/dev-python/debtcollector/debtcollector-2.2.0.ebuild b/dev-python/debtcollector/debtcollector-2.2.0.ebuild
new file mode 100644
index 000000000000..e76434a9b879
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"