summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-10 12:50:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-10 13:03:58 +0200
commit6d9a43f54e24038cf8cf6e5547d3b6f33f16b824 (patch)
tree1e3426bc232b107e57fc34b4b58f32be7695a75c /dev-python
parentdev-python/imageio: drop 2.22.4, 2.23.0 (diff)
downloadgentoo-6d9a43f54e24038cf8cf6e5547d3b6f33f16b824.tar.gz
gentoo-6d9a43f54e24038cf8cf6e5547d3b6f33f16b824.tar.bz2
gentoo-6d9a43f54e24038cf8cf6e5547d3b6f33f16b824.zip
dev-python/tifffile: drop 2022.10.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tifffile/tifffile-2022.10.10.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/tifffile/tifffile-2022.10.10.ebuild b/dev-python/tifffile/tifffile-2022.10.10.ebuild
deleted file mode 100644
index d80014ff6fe7..000000000000
--- a/dev-python/tifffile/tifffile-2022.10.10.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read and write TIFF files"
-HOMEPAGE="
- https://pypi.org/project/tifffile/
- https://github.com/cgohlke/tifffile/
- https://www.cgohlke.com/
-"
-SRC_URI="
- https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/dask[${PYTHON_USEDEP}]
- >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/xarray[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/test_tifffile.py::test_class_omexml
- tests/test_tifffile.py::test_class_omexml_fail
- tests/test_tifffile.py::test_class_omexml_modulo
- tests/test_tifffile.py::test_class_omexml_attributes
- tests/test_tifffile.py::test_class_omexml_multiimage
- tests/test_tifffile.py::test_write_ome
- tests/test_tifffile.py::test_write_ome_manual
- # requires tons of free space
- tests/test_tifffile.py::test_write_3gb
- tests/test_tifffile.py::test_write_bigtiff
- 'tests/test_tifffile.py::test_write_imagej_raw'
- # TODO
- tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
- tests/test_tifffile.py::test_issue_description_overwrite
-)