summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 07:47:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 09:21:09 +0200
commit812812a0f6ed4d1ad469bee32e576b4b2e6edb92 (patch)
tree0e2a474d7b2f255885b72127a9bb26144916aa62 /dev-python
parentdev-python/botocore: Bump to 1.18.1 (diff)
downloadgentoo-812812a0f6ed4d1ad469bee32e576b4b2e6edb92.tar.gz
gentoo-812812a0f6ed4d1ad469bee32e576b4b2e6edb92.tar.bz2
gentoo-812812a0f6ed4d1ad469bee32e576b4b2e6edb92.zip
dev-python/boto3: Bump to 1.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.15.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4134dd766074..70f41002ee6c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.14.46.tar.gz 301815 BLAKE2B e389e7e0cd9ed0907fd13a948bf37e00040e320
DIST boto3-1.14.59.tar.gz 334641 BLAKE2B 96cd0750521715f030c2668cf21b7d6e5f53ffb9bcb84bc9fc540b1bea911591880385a3bd31447f924aa24cbdce873d17241d921b87e57d109173062dd27678 SHA512 9dddad6c71bac90803402b35a316f7177c26629e7e1b3cdadc6222e890d89dce4c2941174501705da85209220fe741f788654f5db164b2d9eac26cbba7cfb0d5
DIST boto3-1.14.63.tar.gz 334965 BLAKE2B 370a1d5bcc32ba6fd8f187fa56fbb3afa4aafa0692245efe024efdefb3d0a314b24873f641b3789430d6a64df70e55743a73760b8282ecaeb64116d9c27b82bc SHA512 668ec7a40d7be74268005d342b568e2d0efe0a3aafca7123c27e966fd89334dbdab04bca0a7ab216eae1f26f0506ef4ccacead49b1714a94a84c7a315e71e505
DIST boto3-1.15.0.tar.gz 335099 BLAKE2B 0cdf8cc0007a90671d4d3c66482d834e24860990bf46634bf542e2e2a025a661d7a45d6be33932581e2697daf5829ca7f47021f863b4219cd3287650bb1ebaa4 SHA512 ed0ddbd4372d591062ef0ce102e6c913842c70921486b09ba1c2901a28d02cf0c41917e246a3654c43382254be32aa5242667199f8a0c2bb9293d7e2cc3827a5
+DIST boto3-1.15.1.tar.gz 335146 BLAKE2B d2d008dcb2059b120f142aaf588264122d1e84b450ab1fbc938627d1c8cc9bb60d1b80e68bc5e538376b56866156ca901abde747a8f973588b64b962284229c4 SHA512 46e1aabaa975b0215c2ece160b5e584468ba19699f87686c2787404d0a13274f763272cec577f830c6c71cb7f9e10b1c317a1348770f49283257d8cba65c5e3a
diff --git a/dev-python/boto3/boto3-1.15.1.ebuild b/dev-python/boto3/boto3-1.15.1.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.15.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}