summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2018-10-12 17:31:39 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2018-10-12 17:31:39 +0200
commit8a4de8d6d057292488298fbb59446696dc112bbc (patch)
treef28f8ce0768e471654496c033cfd791156d1864b /dev-python
parentpackage.mask: Mask <www-client/firefox-60 (diff)
downloadgentoo-8a4de8d6d057292488298fbb59446696dc112bbc.tar.gz
gentoo-8a4de8d6d057292488298fbb59446696dc112bbc.tar.bz2
gentoo-8a4de8d6d057292488298fbb59446696dc112bbc.zip
dev-python/python-evdev: version bump 1.1.2
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-evdev/Manifest1
-rw-r--r--dev-python/python-evdev/python-evdev-1.1.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-evdev/Manifest b/dev-python/python-evdev/Manifest
index 3d75f5890155..29a4fac96c0a 100644
--- a/dev-python/python-evdev/Manifest
+++ b/dev-python/python-evdev/Manifest
@@ -1 +1,2 @@
DIST python-evdev-0.7.0.tar.gz 80508 BLAKE2B 9c3048d649d41b7fc0dfa1af14239a0bfbb5b85c577a8de0323cf35eff79324703987b0a5ec27c06fd277f6ddf76bdd1c7b0b2e589d03ec205c8a7eb0afcad70 SHA512 9757ce392d08f9de0446963cf5351a66dbc2373426bef26e63d71623df1f7c47d90f6e454649076ded214878e67f321380646da3f76bc0fb57f7eb9bbecd3e7a
+DIST python-evdev-1.1.2.tar.gz 83067 BLAKE2B 6434d5c62e4a072928d555bfc92e94e7f63ef98ebbf9cd95795a92d6ccdf7b5d4b0f3133a4b3f2524083b842f78ccc305a5da13af59052be3724d83ea4039328 SHA512 054b2e5af532079dc52919d90791d12d7caf75cade07d18b94ea519869659413ea059570b16ebb236a715c541b17016db380bea4e3c1cd21f96824c6303b45d6
diff --git a/dev-python/python-evdev/python-evdev-1.1.2.ebuild b/dev-python/python-evdev/python-evdev-1.1.2.ebuild
new file mode 100644
index 000000000000..69f32c6049cd
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="https://python-evdev.readthedocs.org/"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ distutils-r1_python_compile build_ecodes \
+ --evdev-headers \
+ "${SYSROOT}"/usr/include/linux/input.h:"${SYSROOT}"/usr/include/linux/input-event-codes.h
+}