summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-12 22:25:10 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-14 00:01:44 +0200
commitd299e18607e7fa7504d554ca75728734c86a92e2 (patch)
tree3896f8e47b2aec2261a7a19461bfdfd6a0805620 /dev-python
parentdev-python/statsd: version bump. (diff)
downloadgentoo-d299e18607e7fa7504d554ca75728734c86a92e2.tar.gz
gentoo-d299e18607e7fa7504d554ca75728734c86a92e2.tar.bz2
gentoo-d299e18607e7fa7504d554ca75728734c86a92e2.zip
dev-python/git-python: version bump.
Closes: https://bugs.gentoo.org/648900 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/git-python/Manifest1
-rw-r--r--dev-python/git-python/git-python-2.1.11.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
index ed5c973f752c..4f1dad252e7f 100644
--- a/dev-python/git-python/Manifest
+++ b/dev-python/git-python/Manifest
@@ -1,2 +1,3 @@
DIST GitPython-1.0.2.tar.gz 387615 BLAKE2B 50915f5ea98a47eeaf086f57ecc0847592721390b7eb38bc3d03e8258c74b4708cb3043142c160139d399337180300037db874d126abb5e54bbae855cd4e8039 SHA512 faff50d5272158f1d05d932e7827c05272f9a28772aabbcabd631b735bb4d8306d2861d13c327d02a4c554bd9a9902c473fb282318036405497dd8bf0fcc51a8
+DIST GitPython-2.1.11.tar.gz 428531 BLAKE2B 18b00f1e622c6588c14e1625f944d117348fb77e67161117510f42c8381db8cde8c6e16fa911edabfc4410239622fb845931b247bab4133585d2ec27969fea4c SHA512 5f964ee56c3f27c28f502150216af29b8463b19d9c0f773458dbabf17ba8587ee5c5e3fbcb31ad46c55e202d06bae447fd40007890a1bc116fe0370cdfc6401f
DIST GitPython-2.1.7.tar.gz 426362 BLAKE2B 1d543b760bc0dbfdf95b120876c1f3454442a2e2bca69529229316fe5345129b852f4f6195066bc4750ac650083750c5ae0f842aeae871cba969aaf4c6563899 SHA512 3081fcf4944d49042fa95b55f1f0a152b405830fa592fbe546710798388e2bd7422bd2c62f5a7545f0820693fe1948ef31e1485d7b6bc2b37f2b807962e7da83
diff --git a/dev-python/git-python/git-python-2.1.11.ebuild b/dev-python/git-python/git-python-2.1.11.ebuild
new file mode 100644
index 000000000000..96f8566ba217
--- /dev/null
+++ b/dev-python/git-python/git-python-2.1.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests only work with the GitPython repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"