summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-12 22:19:22 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-14 00:01:43 +0200
commitf6e02896e129ea0606c1914ac8c6ece7da81930a (patch)
tree52f7b77654d35cd62c27977f1d25b9ddefc67c3e /dev-python
parentdev-python/more-itertools: version bump. (diff)
downloadgentoo-f6e02896e129ea0606c1914ac8c6ece7da81930a.tar.gz
gentoo-f6e02896e129ea0606c1914ac8c6ece7da81930a.tar.bz2
gentoo-f6e02896e129ea0606c1914ac8c6ece7da81930a.zip
dev-python/statsd: version bump.
Closes: https://bugs.gentoo.org/647488 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/statsd/Manifest1
-rw-r--r--dev-python/statsd/statsd-3.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/statsd/Manifest b/dev-python/statsd/Manifest
index f8edd8c62a22..0ebc57642f68 100644
--- a/dev-python/statsd/Manifest
+++ b/dev-python/statsd/Manifest
@@ -1 +1,2 @@
DIST statsd-3.2.1.tar.gz 166047 BLAKE2B b0bf102823cefb8a698b759881ebb395c7408b8b5fff7cf304aaa0ecbad2fa8381fe05efa3cdd9c36c44c7188e46173235f9fe2cbed9fb940d8d5231f455d6bc SHA512 c5166fabcef2158aeb29b07b9bd1d241bc30847eb0e2c7694ee097b3a262e2590189ee10daecb368807002bd96fed16e749ca744b51b5e946d48fe2931a0d8e8
+DIST statsd-3.3.0.tar.gz 259045 BLAKE2B 015eb32d40d1eb45d64266f0bd62d9496a7eb8815dccf4ad482bb3b81b45fceef14a25893b05ad3b5a8da8582434a46725598a90ebd06c6120dac32169a1f201 SHA512 e2693bc7f179e275c53044d13a4685dd72ebd47adafcab5064e803fbf9e8df4a0f20f61c3695846d3c33178be17dd7286f487213fa2bd8545ed1612e200c8f36
diff --git a/dev-python/statsd/statsd-3.3.0.ebuild b/dev-python/statsd/statsd-3.3.0.ebuild
new file mode 100644
index 000000000000..df10878f5be5
--- /dev/null
+++ b/dev-python/statsd/statsd-3.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple statsd client"
+HOMEPAGE="https://github.com/jsocol/pystatsd https://pypi.org/project/statsd"
+
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}