summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-10 11:20:31 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-10 11:58:14 +0200
commitea1c31d0fcd15efcdc9c42604ee976ac8ded5c36 (patch)
treedefa11769cefadabeec76e16a197eeefa0a68e74 /dev-python
parentdev-python/jupyter_server: add new dep of nbdime (diff)
downloadgentoo-ea1c31d0fcd15efcdc9c42604ee976ac8ded5c36.tar.gz
gentoo-ea1c31d0fcd15efcdc9c42604ee976ac8ded5c36.tar.bz2
gentoo-ea1c31d0fcd15efcdc9c42604ee976ac8ded5c36.zip
dev-python/tomlkit: add new dep of jupyter_packaging
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/metadata.xml13
-rw-r--r--dev-python/tomlkit/tomlkit-0.7.2.ebuild18
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
new file mode 100644
index 000000000000..9229d0898d57
--- /dev/null
+++ b/dev-python/tomlkit/Manifest
@@ -0,0 +1 @@
+DIST tomlkit-0.7.2.tar.gz 159643 BLAKE2B 6946cdc4c991671eb9e38cf836196a0dfdb7aba2697db95f3fcee58652d3c8ba96295df447b8145f0143447339834015abbd60928d7588c68ae31c298fd6d2d4 SHA512 cfb17d133463c22ae8b76dd03587f23f6dafedfd2decdf15ae29fe5c05117ebd3e17057f49bdb17345386f5ce3073b1e5b1937c6ab6683aefb0fc0abd7571580
diff --git a/dev-python/tomlkit/metadata.xml b/dev-python/tomlkit/metadata.xml
new file mode 100644
index 000000000000..3fbb877c5ee2
--- /dev/null
+++ b/dev-python/tomlkit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">tomlkit</remote-id>
+ <remote-id type="github">sdispater/tomlkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tomlkit/tomlkit-0.7.2.ebuild b/dev-python/tomlkit/tomlkit-0.7.2.ebuild
new file mode 100644
index 000000000000..b90a5d8b8c84
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.7.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="https://github.com/sdispater/tomlkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest