summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-04 16:42:48 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-04 18:58:03 -0400
commitff9bfc20deac3e035a5e7ce59345d0f123a2f10a (patch)
tree3cff2edb66a990e9a833de28a9f70a4531adc512 /dev-python
parentdev-python/jupyter_core: drop py2 (diff)
downloadgentoo-ff9bfc20deac3e035a5e7ce59345d0f123a2f10a.tar.gz
gentoo-ff9bfc20deac3e035a5e7ce59345d0f123a2f10a.tar.bz2
gentoo-ff9bfc20deac3e035a5e7ce59345d0f123a2f10a.zip
dev-python/jupyter_client: drop py2
Bug: https://bugs.gentoo.org/685040 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild
new file mode 100644
index 000000000000..470782ffa021
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ pytest -vv jupyter_client || die
+}