summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 11:42:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:42:44 +0200
commit7d78ab428f86afc75371d028ec5987e7e4e11886 (patch)
tree5fdc96a636058a307d4b6b0f335151a3fe14e907 /dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild
parentdev-ros/gazebo_plugins: Bump to 2.5.3. (diff)
downloadgentoo-7d78ab428f86afc75371d028ec5987e7e4e11886.tar.gz
gentoo-7d78ab428f86afc75371d028ec5987e7e4e11886.tar.bz2
gentoo-7d78ab428f86afc75371d028ec5987e7e4e11886.zip
dev-ros/gazebo_ros: Bump to 2.5.3.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild')
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild
new file mode 100644
index 000000000000..870276d41866
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"