summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:56:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit451aa564a8b2995e4c58578a4331565f38f86a24 (patch)
tree80acec72ac24885cc51fc7735b21d39c2cd13245 /dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild
parentdev-ros/rotate_recovery: Initial import. Ebuild by me. (diff)
downloadgentoo-451aa564a8b2995e4c58578a4331565f38f86a24.tar.gz
gentoo-451aa564a8b2995e4c58578a4331565f38f86a24.tar.bz2
gentoo-451aa564a8b2995e4c58578a4331565f38f86a24.zip
dev-ros/move_slow_and_clear: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild')
-rw-r--r--dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild b/dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild
new file mode 100644
index 000000000000..18fca39ec649
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Move slow and clear"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+
+"