summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-06 09:07:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-06 09:07:21 +0200
commit4ab06080629e5ea001cbe849067c9cdaa8ec5def (patch)
tree9b56c05e6091d2806b414629e1975381ba955124 /dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
parentdev-ros/qt_gui_cpp: Bump to 0.3.6. (diff)
downloadgentoo-4ab06080629e5ea001cbe849067c9cdaa8ec5def.tar.gz
gentoo-4ab06080629e5ea001cbe849067c9cdaa8ec5def.tar.bz2
gentoo-4ab06080629e5ea001cbe849067c9cdaa8ec5def.zip
dev-ros/qt_gui_py_common: Bump to 0.3.6.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
new file mode 100644
index 000000000000..87a1c621b8d2
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"