summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:00:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:29 +0200
commitc92666b2376bb3273e440312d61a342facd0345b (patch)
tree24f720dec9a649688bb51b128c73ee4e25973028 /dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild
parentdev-ros/test_rosbag: Initial import. Ebuild by me. (diff)
downloadgentoo-c92666b2376bb3273e440312d61a342facd0345b.tar.gz
gentoo-c92666b2376bb3273e440312d61a342facd0345b.tar.bz2
gentoo-c92666b2376bb3273e440312d61a342facd0345b.zip
dev-ros/test_rosbag_storage: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild')
-rw-r--r--dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild b/dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild
new file mode 100644
index 000000000000..1bdd56f7c94a
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag_storage"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rosbag_storage
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ test? ( dev-cpp/gtest )"