summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-27 10:51:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-27 10:53:48 +0200
commit102a6e92ee17eddcc14354173023e6793cb526d4 (patch)
tree99ca0c82cbde8604b0f46244106259ad1bb8b1aa /dev-ros/test_roscpp
parentdev-ros/controller_manager_tests: tests are always built (diff)
downloadgentoo-102a6e92ee17eddcc14354173023e6793cb526d4.tar.gz
gentoo-102a6e92ee17eddcc14354173023e6793cb526d4.tar.bz2
gentoo-102a6e92ee17eddcc14354173023e6793cb526d4.zip
dev-ros/test_roscpp: serialize tests
Closes: https://bugs.gentoo.org/738620 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild4
-rw-r--r--dev-ros/test_roscpp/test_roscpp-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
index 39bfc4bf09a4..6162bbe7696c 100644
--- a/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
@@ -32,5 +32,7 @@ PATCHES=( "${FILESDIR}/tests.patch" )
src_test() {
export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
+ # Sometimes high number of tests running in parallel make them fail
+ # https://bugs.gentoo.org/738620
+ ros-catkin_src_test -j 1
}
diff --git a/dev-ros/test_roscpp/test_roscpp-9999.ebuild b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
index 39bfc4bf09a4..6162bbe7696c 100644
--- a/dev-ros/test_roscpp/test_roscpp-9999.ebuild
+++ b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
@@ -32,5 +32,7 @@ PATCHES=( "${FILESDIR}/tests.patch" )
src_test() {
export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
+ # Sometimes high number of tests running in parallel make them fail
+ # https://bugs.gentoo.org/738620
+ ros-catkin_src_test -j 1
}