summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:05:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:41 +0200
commit6b8047748e84096ab9998ec730d02aae9c02185b (patch)
tree23221d3ba7d446dbc4d4b815595d7f9f34153723 /dev-ros/test_rosservice
parentdev-ros/topic_tools: convert to python signle (diff)
downloadgentoo-6b8047748e84096ab9998ec730d02aae9c02185b.tar.gz
gentoo-6b8047748e84096ab9998ec730d02aae9c02185b.tar.bz2
gentoo-6b8047748e84096ab9998ec730d02aae9c02185b.zip
dev-ros/test_rosservice: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosservice')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild10
-rw-r--r--dev-ros/test_rosservice/test_rosservice-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild b/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild
index 7a943471ee43..f3a0192eb698 100644
--- a/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild
+++ b/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild
@@ -18,11 +18,11 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
test? (
- dev-ros/test_rosmaster[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
diff --git a/dev-ros/test_rosservice/test_rosservice-9999.ebuild b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
index 7a943471ee43..f3a0192eb698 100644
--- a/dev-ros/test_rosservice/test_rosservice-9999.ebuild
+++ b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
@@ -18,11 +18,11 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
test? (
- dev-ros/test_rosmaster[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"