summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosservice')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild10
-rw-r--r--dev-ros/test_rosservice/test_rosservice-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild b/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild
index 7a943471ee43..f3a0192eb698 100644
--- a/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild
+++ b/dev-ros/test_rosservice/test_rosservice-1.15.7.ebuild
@@ -18,11 +18,11 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
test? (
- dev-ros/test_rosmaster[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
diff --git a/dev-ros/test_rosservice/test_rosservice-9999.ebuild b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
index 7a943471ee43..f3a0192eb698 100644
--- a/dev-ros/test_rosservice/test_rosservice-9999.ebuild
+++ b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
@@ -18,11 +18,11 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
test? (
- dev-ros/test_rosmaster[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"