summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 08:57:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 08:57:21 +0200
commit9db5f592df9be98d59b6caf2a9bea848d0e6ceaf (patch)
tree502abde346231c9a3209ee0440d9cedebae4031d /dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.3.ebuild
parentdev-ros/tf2_ros: Bump to 0.6.3. (diff)
downloadgentoo-9db5f592df9be98d59b6caf2a9bea848d0e6ceaf.tar.gz
gentoo-9db5f592df9be98d59b6caf2a9bea848d0e6ceaf.tar.bz2
gentoo-9db5f592df9be98d59b6caf2a9bea848d0e6ceaf.zip
dev-ros/tf2_sensor_msgs: Bump to 0.6.3.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.3.ebuild')
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.3.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.3.ebuild
new file mode 100644
index 000000000000..b4c841429ce6
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/cmake_modules"