summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-05 21:40:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-06 10:49:45 +0200
commitf8fb05796886ad462c3c819aa87df7c2701fd34c (patch)
treee73a875b33c3e82439c2f843cbe4d5204261cadc /dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild
parentdev-ros/pluginlib_tutorials: Bump to 0.1.11. (diff)
downloadgentoo-f8fb05796886ad462c3c819aa87df7c2701fd34c.tar.gz
gentoo-f8fb05796886ad462c3c819aa87df7c2701fd34c.tar.bz2
gentoo-f8fb05796886ad462c3c819aa87df7c2701fd34c.zip
dev-ros/turtle_actionlib: Bump to 0.1.11.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild')
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild
new file mode 100644
index 000000000000..24600b2d603f
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"