summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-20 09:11:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-22 13:27:51 +0200
commit316abd8390c38492ba1606335654f82da1507965 (patch)
tree401dc485a51febfa41ef8db6219557aae8f89572 /dev-ros
parentsys-process/procps: Stable for HPPA too. (diff)
downloadgentoo-316abd8390c38492ba1606335654f82da1507965.tar.gz
gentoo-316abd8390c38492ba1606335654f82da1507965.tar.bz2
gentoo-316abd8390c38492ba1606335654f82da1507965.zip
dev-ros/geometric_shapes: Remove old
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/geometric_shapes/Manifest1
-rw-r--r--dev-ros/geometric_shapes/files/logging.patch213
-rw-r--r--dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild31
3 files changed, 0 insertions, 245 deletions
diff --git a/dev-ros/geometric_shapes/Manifest b/dev-ros/geometric_shapes/Manifest
index 7fc11382864f..b7055d4c6a9c 100644
--- a/dev-ros/geometric_shapes/Manifest
+++ b/dev-ros/geometric_shapes/Manifest
@@ -1,2 +1 @@
-DIST geometric_shapes-0.5.3.tar.gz 60799 BLAKE2B 77bfde8f7b1f3e11bd4bb12c82374e34ca0efc0f75125a1c5a58d4ce797feb70b70803526f4b8cbdf651d762082a4bbcb03df5e6ace2bdc69ed84be20a963731 SHA512 13c1b85cab4d0d5d35bd010927a5fd789312b4c11667ee73295722067968504054a8f24628db2f78782078ff3cbcd6878bd403979c29526b2183c3ae2414b2b1
DIST geometric_shapes-0.5.4.tar.gz 62028 BLAKE2B 6873019c54872077ec88ad6107bdf1a69092d73bd1f73b38dbbdcd88a3e5da9cfffd0782ec2e01f87fd90082ed856e3a2f5161dec606ba08c0510752a813359c SHA512 bd0909fb0feeddebf65793aa77a6803217e39e782767cd2d58b26266ff79018ebb352c77385e20043a069caaa7e00ba63366a703d52605562e8535f1d3af2dac
diff --git a/dev-ros/geometric_shapes/files/logging.patch b/dev-ros/geometric_shapes/files/logging.patch
deleted file mode 100644
index 06036ad5dcee..000000000000
--- a/dev-ros/geometric_shapes/files/logging.patch
+++ /dev/null
@@ -1,213 +0,0 @@
-https://github.com/ros-planning/geometric_shapes/issues/71
-
-Index: geometric_shapes-0.5.3/src/bodies.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/bodies.cpp
-+++ geometric_shapes-0.5.3/src/bodies.cpp
-@@ -788,7 +788,7 @@ void bodies::ConvexMesh::useDimensions(c
-
- if (exitcode != 0)
- {
-- logWarn("Convex hull creation failed");
-+ CONSOLE_BRIDGE_logWarn("Convex hull creation failed");
- qh_freeqhull (!qh_ALL);
- int curlong, totlong;
- qh_memfreeshort (&curlong, &totlong);
-@@ -1174,7 +1174,7 @@ void bodies::BodyVector::setPose(unsigne
- {
- if (i >= bodies_.size())
- {
-- logError("There is no body at index %u", i);
-+ CONSOLE_BRIDGE_logError("There is no body at index %u", i);
- return;
- }
-
-@@ -1185,7 +1185,7 @@ const bodies::Body* bodies::BodyVector::
- {
- if (i >= bodies_.size())
- {
-- logError("There is no body at index %u", i);
-+ CONSOLE_BRIDGE_logError("There is no body at index %u", i);
- return NULL;
- }
- else
-Index: geometric_shapes-0.5.3/src/body_operations.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/body_operations.cpp
-+++ geometric_shapes-0.5.3/src/body_operations.cpp
-@@ -59,7 +59,7 @@ bodies::Body* bodies::createBodyFromShap
- body = new bodies::ConvexMesh(shape);
- break;
- default:
-- logError("Creating body from shape: Unknown shape type %d", (int)shape->type);
-+ CONSOLE_BRIDGE_logError("Creating body from shape: Unknown shape type %d", (int)shape->type);
- break;
- }
-
-@@ -112,7 +112,7 @@ Body* constructBodyFromMsgHelper(const T
- Eigen::Quaterniond q(pose.orientation.w, pose.orientation.x, pose.orientation.y, pose.orientation.z);
- if (fabs(q.squaredNorm() - 1.0) > 1e-3)
- {
-- logError("Quaternion is not normalized. Assuming identity.");
-+ CONSOLE_BRIDGE_logError("Quaternion is not normalized. Assuming identity.");
- q = Eigen::Quaterniond(1.0, 0.0, 0.0, 0.0);
- }
- Eigen::Affine3d af(Eigen::Translation3d(pose.position.x, pose.position.y, pose.position.z) * q.toRotationMatrix());
-Index: geometric_shapes-0.5.3/src/mesh_operations.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/mesh_operations.cpp
-+++ geometric_shapes-0.5.3/src/mesh_operations.cpp
-@@ -133,7 +133,7 @@ Mesh* createMeshFromVertices(const Eigen
- return NULL;
-
- if (source.size() % 3 != 0)
-- logError("The number of vertices to construct a mesh from is not divisible by 3. Probably constructed triangles will not make sense.");
-+ CONSOLE_BRIDGE_logError("The number of vertices to construct a mesh from is not divisible by 3. Probably constructed triangles will not make sense.");
-
- std::set<detail::LocalVertexType, detail::ltLocalVertexValue> vertices;
- std::vector<unsigned int> triangles;
-@@ -220,7 +220,7 @@ Mesh* createMeshFromBinary(const char *b
- {
- if (!buffer || size < 1)
- {
-- logWarn("Cannot construct mesh from empty binary buffer");
-+ CONSOLE_BRIDGE_logWarn("Cannot construct mesh from empty binary buffer");
- return NULL;
- }
-
-@@ -285,21 +285,21 @@ Mesh* createMeshFromResource(const std::
- }
- catch (resource_retriever::Exception& e)
- {
-- logError("%s", e.what());
-+ CONSOLE_BRIDGE_logError("%s", e.what());
- return NULL;
- }
-
- if (res.size == 0)
- {
-- logWarn("Retrieved empty mesh for resource '%s'", resource.c_str());
-+ CONSOLE_BRIDGE_logWarn("Retrieved empty mesh for resource '%s'", resource.c_str());
- return NULL;
- }
-
- Mesh *m = createMeshFromBinary(reinterpret_cast<const char*>(res.data.get()), res.size, scale, resource);
- if (!m)
- {
-- logWarn("Assimp reports no scene in %s.", resource.c_str());
-- logWarn("This could be because of a resource filename that is too long for the Assimp library, a known bug. As a workaround shorten the filename/path.");
-+ CONSOLE_BRIDGE_logWarn("Assimp reports no scene in %s.", resource.c_str());
-+ CONSOLE_BRIDGE_logWarn("This could be because of a resource filename that is too long for the Assimp library, a known bug. As a workaround shorten the filename/path.");
- }
- return m;
- }
-@@ -344,7 +344,7 @@ Mesh* createMeshFromAsset(const aiScene*
- {
- if (!scene->HasMeshes())
- {
-- logWarn("Assimp reports scene in %s has no meshes", resource_name.c_str());
-+ CONSOLE_BRIDGE_logWarn("Assimp reports scene in %s has no meshes", resource_name.c_str());
- return NULL;
- }
- EigenSTL::vector_Vector3d vertices;
-@@ -352,12 +352,12 @@ Mesh* createMeshFromAsset(const aiScene*
- extractMeshData(scene, scene->mRootNode, aiMatrix4x4(), scale, vertices, triangles);
- if (vertices.empty())
- {
-- logWarn("There are no vertices in the scene %s", resource_name.c_str());
-+ CONSOLE_BRIDGE_logWarn("There are no vertices in the scene %s", resource_name.c_str());
- return NULL;
- }
- if (triangles.empty())
- {
-- logWarn("There are no triangles in the scene %s", resource_name.c_str());
-+ CONSOLE_BRIDGE_logWarn("There are no triangles in the scene %s", resource_name.c_str());
- return NULL;
- }
-
-@@ -378,7 +378,7 @@ Mesh* createMeshFromShape(const Shape *s
- if (shape->type == shapes::CONE)
- return shapes::createMeshFromShape(static_cast<const shapes::Cone&>(*shape));
- else
-- logError("Conversion of shape of type '%s' to a mesh is not known", shapeStringName(shape).c_str());
-+ CONSOLE_BRIDGE_logError("Conversion of shape of type '%s' to a mesh is not known", shapeStringName(shape).c_str());
- return NULL;
- }
-
-Index: geometric_shapes-0.5.3/src/shape_operations.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/shape_operations.cpp
-+++ geometric_shapes-0.5.3/src/shape_operations.cpp
-@@ -62,7 +62,7 @@ Shape* constructShapeFromMsg(const shape
- {
- if (shape_msg.triangles.empty() || shape_msg.vertices.empty())
- {
-- logWarn("Mesh definition is empty");
-+ CONSOLE_BRIDGE_logWarn("Mesh definition is empty");
- return NULL;
- }
- else
-@@ -117,7 +117,7 @@ Shape* constructShapeFromMsg(const shape
- shape_msg.dimensions[shape_msgs::SolidPrimitive::CONE_HEIGHT]);
- }
- if (shape == NULL)
-- logError("Unable to construct shape corresponding to shape_msg of type %d", (int)shape_msg.type);
-+ CONSOLE_BRIDGE_logError("Unable to construct shape corresponding to shape_msg of type %d", (int)shape_msg.type);
-
- return shape;
- }
-@@ -202,7 +202,7 @@ bool constructMarkerFromShape(const Shap
- }
- catch (std::runtime_error &ex)
- {
-- logError("%s", ex.what());
-+ CONSOLE_BRIDGE_logError("%s", ex.what());
- }
- if (ok)
- return true;
-@@ -451,7 +451,7 @@ bool constructMsgFromShape(const Shape*
- }
- else
- {
-- logError("Unable to construct shape message for shape of type %d", (int)shape->type);
-+ CONSOLE_BRIDGE_logError("Unable to construct shape message for shape of type %d", (int)shape->type);
- return false;
- }
-
-@@ -512,7 +512,7 @@ void saveAsText(const Shape *shape, std:
- }
- else
- {
-- logError("Unable to save shape of type %d", (int)shape->type);
-+ CONSOLE_BRIDGE_logError("Unable to save shape of type %d", (int)shape->type);
- }
- }
-
-@@ -580,7 +580,7 @@ Shape* constructShapeFromText(std::istre
- m->computeVertexNormals();
- }
- else
-- logError("Unknown shape type: '%s'", type.c_str());
-+ CONSOLE_BRIDGE_logError("Unknown shape type: '%s'", type.c_str());
- }
- }
- return result;
-Index: geometric_shapes-0.5.3/src/shapes.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/shapes.cpp
-+++ geometric_shapes-0.5.3/src/shapes.cpp
-@@ -224,12 +224,12 @@ shapes::Shape* shapes::OcTree::clone() c
-
- void shapes::OcTree::scaleAndPadd(double scale, double padd)
- {
-- logWarn("OcTrees cannot be scaled or padded");
-+ CONSOLE_BRIDGE_logWarn("OcTrees cannot be scaled or padded");
- }
-
- void shapes::Plane::scaleAndPadd(double scale, double padding)
- {
-- logWarn("Planes cannot be scaled or padded");
-+ CONSOLE_BRIDGE_logWarn("Planes cannot be scaled or padded");
- }
-
- void shapes::Shape::scale(double scale)
diff --git a/dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild b/dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild
deleted file mode 100644
index 54b4e296f9f0..000000000000
--- a/dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-planning/geometric_shapes"
-KEYWORDS="~amd64 ~arm"
-
-inherit ros-catkin
-
-DESCRIPTION="Generic definitions of geometric shapes and bodies"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-cpp/eigen:3
- dev-libs/boost:=
- media-libs/qhull
- media-libs/assimp
- sci-libs/octomap
- dev-ros/random_numbers
- dev-ros/resource_retriever
- dev-ros/eigen_stl_containers
- dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/console_bridge:=
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest dev-ros/rosunit )
-"
-PATCHES=( "${FILESDIR}/logging.patch" )