summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-09 17:38:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-09 17:38:45 +0200
commit5b85a80a3db6f7df39b28ca77dc50d18714c5cbc (patch)
tree5047acbab9b97bded93e0d4ac207c723c18109a1 /dev-ros
parentdev-ros/smach: Bump to 2.0.1. (diff)
downloadgentoo-5b85a80a3db6f7df39b28ca77dc50d18714c5cbc.tar.gz
gentoo-5b85a80a3db6f7df39b28ca77dc50d18714c5cbc.tar.bz2
gentoo-5b85a80a3db6f7df39b28ca77dc50d18714c5cbc.zip
dev-ros/smach_ros: Bump to 2.0.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/smach_ros/Manifest1
-rw-r--r--dev-ros/smach_ros/smach_ros-2.0.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/smach_ros/Manifest b/dev-ros/smach_ros/Manifest
index 4bc8b5a913a1..50d925fd84a6 100644
--- a/dev-ros/smach_ros/Manifest
+++ b/dev-ros/smach_ros/Manifest
@@ -1 +1,2 @@
DIST executive_smach-2.0.0.tar.gz 39920 SHA256 48f11db9a1be8accf6bce4dc20efa825f8fab1697d8620690eb51051ddd2c6b3 SHA512 e1970128f2a49e92e99821922351cb62c64d4367781397f6f6b3c20691c2712824edabe4e4a67264fe48555f3b0c8d1f1fd7bc8820fb6f5937f7c6a22815c601 WHIRLPOOL 045578126017e77486c4e87dd85badbff8a8227e580ba792389fe871c732455bc5d1abcb83cff230705ff85a1679682f9a99541727fcb253858e02cd33dc0184
+DIST executive_smach-2.0.1.tar.gz 42032 SHA256 2f7f58064c960fc56de15fdedfd883f62122bd44874787f13c8b4d8a77c45380 SHA512 88be9ad6a0ec1e82e1592d26621fbbfe24e45640266f369cd03f192649bfd865e5a4ea576cf665161c0f89805e67b38b8b64b62a054ca1e217b99d8284f3b32a WHIRLPOOL 69b12a64c5826e27447e2e5adbff9462369d41b1e6b2e88561b758c19019c8233400a98e01146b8a34b38f66ad9678cf58a8373fed72d07640bb56fb9a26256d
diff --git a/dev-ros/smach_ros/smach_ros-2.0.1.ebuild b/dev-ros/smach_ros/smach_ros-2.0.1.ebuild
new file mode 100644
index 000000000000..d3df8eeab34e
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"