summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/bundler-audit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/bundler-audit')
-rw-r--r--dev-ruby/bundler-audit/Manifest2
-rw-r--r--dev-ruby/bundler-audit/bundler-audit-0.3.1.ebuild20
-rw-r--r--dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild40
-rw-r--r--dev-ruby/bundler-audit/metadata.xml10
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/bundler-audit/Manifest b/dev-ruby/bundler-audit/Manifest
new file mode 100644
index 000000000000..01a8cd737f54
--- /dev/null
+++ b/dev-ruby/bundler-audit/Manifest
@@ -0,0 +1,2 @@
+DIST bundler-audit-0.3.1.gem 47104 SHA256 ee1101bda2740e75f3cae29af1614664b18f51193a235cc8b4042449dfb4eb0c SHA512 e27714d1edf8681b38433a64087c6c6ccb2d073bd807d2eed2f4153188b8151b98ffd9e5979827752b83f1b1fab09399d3421acc1045355439b2d95c500a7b32 WHIRLPOOL abe8ebf9f8cce2e9e7ee4c27fb0549190eafe6113e9ce54b74229d1ac1de38e71b490df5b1137c78665b642add18fafeebccfafa39744942e589bc02ed542d7b
+DIST bundler-audit-0.4.0.gem 48128 SHA256 db4d0570bb09057bb9194bd77999ced6955569c287db450b55c79f23c41c5b57 SHA512 d6e362186c7234bac9184d026d0ae125c22bb6bb54a8a681b6b76adfe9886acec4a724291d3db058b6afb1c42f026bf4bae0969d3751b1299364f726b78f14fa WHIRLPOOL aee50d885f4ff1bb7fadc88bea8965823118066809966c1a40f4f535959c9eb884eef3eaf39cc3d419db7da65ce091349a3cf6a4f2acd26b80a28baa4bf6ef14
diff --git a/dev-ruby/bundler-audit/bundler-audit-0.3.1.ebuild b/dev-ruby/bundler-audit/bundler-audit-0.3.1.ebuild
new file mode 100644
index 000000000000..5bba6de67dd5
--- /dev/null
+++ b/dev-ruby/bundler-audit/bundler-audit-0.3.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/rubysec/bundler-audit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+RESTRICT="test"
+
+ruby_add_rdepend "dev-ruby/thor dev-ruby/bundler"
diff --git a/dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild b/dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild
new file mode 100644
index 000000000000..2ae9f576ab1e
--- /dev/null
+++ b/dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides patch-level verification for Bundled apps"
+HOMEPAGE="https://github.com/rubysec/bundler-audit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/thor-0.18:0
+ >=dev-ruby/bundler-1.2:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that require network access via 'bundle install'
+ rm spec/{integration,scanner}_spec.rb || die
+
+ # Avoid specs that only work when the source is a git repository
+ sed -i -e '/describe "path"/,/^ end/ s:^:#:' \
+ -e '/describe "update!"/,/^ end/ s:^:#:' \
+ spec/database_spec.rb || die
+}
diff --git a/dev-ruby/bundler-audit/metadata.xml b/dev-ruby/bundler-audit/metadata.xml
new file mode 100644
index 000000000000..c31d97eb2e6a
--- /dev/null
+++ b/dev-ruby/bundler-audit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">rubysec/bundler-audit</remote-id>
+ </upstream>
+</pkgmetadata>