summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/classifier
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/classifier')
-rw-r--r--dev-ruby/classifier/Manifest1
-rw-r--r--dev-ruby/classifier/classifier-1.3.4.ebuild34
-rw-r--r--dev-ruby/classifier/metadata.xml8
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/classifier/Manifest b/dev-ruby/classifier/Manifest
new file mode 100644
index 000000000000..5117a2522f3b
--- /dev/null
+++ b/dev-ruby/classifier/Manifest
@@ -0,0 +1 @@
+DIST classifier-1.3.4.gem 26112 SHA256 ac5754c0d607b58af008afd479b6bbb3a8d6c1cef04677d335f57846c5455a5d SHA512 b59fe17f7fe508d5f26584e14d5cd89eed8f77756b75a65adf2512116d0a67b716d14c2f742270fd14765567079a88264f5e1afe49d3865403814c4bdaf8f2f1 WHIRLPOOL 63ed89f55b53309afa789ccb0fefeba5f1d53434eb67e60c06270b31e2922d197fd99b41119f0e08e4ad967c8c13d1f840371f0ce039389b346c4ef67c3ebbdb
diff --git a/dev-ruby/classifier/classifier-1.3.4.ebuild b/dev-ruby/classifier/classifier-1.3.4.ebuild
new file mode 100644
index 000000000000..58ee5eba199a
--- /dev/null
+++ b/dev-ruby/classifier/classifier-1.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="http://rubyforge.org/projects/classifier https://github.com/cardmagic/classifier"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier-reborn
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "s/PKG_VERSION/\"${PV}\"/" \
+ -e "s#PKG_FILES#FileList[ \"lib/**/*\", \"bin/*\", \"test/**/*\", \"[A-Z]*\", \"Rakefile\", \"Gemfile\", \"html/**/*\"]#" Rakefile
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/' -i lib/${PN}/lsi.rb || die
+ rm test/lsi/lsi_test.rb || die
+ fi
+ # Remove failing test for now
+ rm test/extensions/word_hash_test.rb || die
+}
diff --git a/dev-ruby/classifier/metadata.xml b/dev-ruby/classifier/metadata.xml
new file mode 100644
index 000000000000..471aa439f6a3
--- /dev/null
+++ b/dev-ruby/classifier/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">cardmagic/classifier</remote-id>
+ </upstream>
+</pkgmetadata>